auxiliary bus driver · Supported
Maintainers
- M Greg Kroah-Hartman <gregkh@linuxfoundation.org>
- M "Rafael J. Wysocki" <rafael@kernel.org>
- M Danilo Krummrich <dakr@kernel.org>
- R Dave Ertman <david.m.ertman@intel.com>
- R Ira Weiny <iweiny@kernel.org>
- R Leon Romanovsky <leon@kernel.org>
Paths
- F
Documentation/driver-api/auxiliary_bus.rst - F
drivers/base/auxiliary.c - F
include/linux/auxiliary_bus.h - F
rust/helpers/auxiliary.c - F
rust/kernel/auxiliary.rs - F
samples/rust/rust_driver_auxiliary.rs
Last 30 days
Most active threads (last 7 days)
-
COOLING4d
[PATCH v2 00/11] rust: driver: use pointers instead of indices for ID info
2026-06-29 12:40 · 4 replies in 7d · Gary Guo <gary@garyguo.net>
Active reviewers (last 30 days)
-
Danilo Krummrich <dakr@kernel.org>
2 attestations (2 Acked-by) · last on 2026-06-27
Recent patches
Most-recent 30 patches in this subsystem on netdev (capped at 30), ordered by date desc.
-
COOLING4d
[PATCH v2 06/11] rust: driver: centralize device ID handling
2026-06-29 · Gary Guo <gary@garyguo.net> -
COOLING4d
[PATCH v2 08/11] rust: driver: store pointers in `DeviceId`
2026-06-29 · Gary Guo <gary@garyguo.net> -
COOLING4d
[PATCH v2 07/11] rust: driver: remove `$module_table_name` from `module_device_table`
2026-06-29 · Gary Guo <gary@garyguo.net> -
COOLING4d
[PATCH v2 03/11] rust: pci: use `Option<&IdInfo>` for device ID info
2026-06-29 · Gary Guo <gary@garyguo.net> -
COOLING8d
REVIEWED: 15 (15M) [PATCH v7 01/10] rust: module: move module types into `module.rs`
2026-06-27 · Alvin Sun <hidden> -
COOLING7d
REVIEWED: 15 (15M) [PATCH v6 01/10] rust: module: move module types into `module.rs`
2026-06-24 · Alvin Sun <hidden> -
COOLING10d
[PATCH v5 1/9] rust: module: move module types into `module.rs`
2026-06-24 · Alvin Sun <hidden> -
COOLING11d
[PATCH v4 1/9] rust: module: move module types into `module.rs`
2026-06-23 · Alvin Sun <hidden> -
COLD15d
[PATCH 06/10] rust: driver: remove `$module_table_name` from `module_device_table`
2026-06-18 · Gary Guo <gary@garyguo.net> -
COLD15d
[PATCH 05/10] rust: driver: centralize device ID handling
2026-06-18 · Gary Guo <gary@garyguo.net> -
COLD15d
[PATCH 07/10] rust: driver: store pointers in `DeviceId`
2026-06-18 · Gary Guo <gary@garyguo.net> -
COLD15d
[PATCH 03/10] rust: pci: use `Option<&IdInfo>` for device ID info
2026-06-18 · Gary Guo <gary@garyguo.net> -
STALE132d
REVIEWED: 4 (4M) [PATCH V2] driver core: auxiliary bus: Fix sysfs creation on bind
2026-02-19 · Tariq Toukan <tariqt@nvidia.com> -
STALE194d
REVIEWED: 47 (47M) [PATCH v2 03/19] rust: auxiliary: replace `kernel::c_str!` with C-Strings
2025-09-25 · Tamir Duberstein <hidden> -
STALE323d
REVIEWED: 47 (47M) [PATCH v2 03/19] rust: auxiliary: replace `kernel::c_str!` with C-Strings
2025-08-13 · Tamir Duberstein <hidden> -
STALE292d
REVIEWED: 47 (47M) [PATCH v3 02/11] rust: auxiliary: use `core::ffi::CStr` method names
2025-08-13 · Tamir Duberstein <hidden> -
STALE330d
REVIEWED: 47 (47M) [PATCH v2 02/10] rust: auxiliary: use `core::ffi::CStr` method names
2025-07-19 · Tamir Duberstein <hidden> -
STALE342d
[PATCH net v2 1/4] auxiliary: Support hexadecimal ids
2025-07-16 · Sean Anderson <sean.anderson@linux.dev> -
STALE353d
LANDED [PATCH v2 1/2] device: rust: rename Device::as_ref() to Device::from_raw()
2025-07-11 · Alice Ryhl <aliceryhl@google.com> -
STALE353d
LANDED: 19 (19M) [PATCH v4 1/3] rust: device_id: split out index support into a separate trait
2025-07-11 · FUJITA Tomonori <fujita.tomonori@gmail.com> -
STALE333d
REVIEWED: 30 (30M) [PATCH 03/17] rust: auxiliary: replace `kernel::c_str!` with C-Strings
2025-07-10 · Tamir Duberstein <hidden> -
STALE355d
REVIEWED: 30 (30M) [PATCH 02/10] rust: auxiliary: use `core::ffi::CStr` method names
2025-07-09 · Tamir Duberstein <hidden> -
STALE360d
[PATCH] drm: rust: rename Device::as_ref() to Device::from_raw()
2025-07-09 · Alice Ryhl <aliceryhl@google.com> -
STALE359d
REVIEWED: 15 (15M) [PATCH v3 1/3] rust: device_id: split out index support into a separate trait
2025-07-04 · FUJITA Tomonori <fujita.tomonori@gmail.com> -
STALE365d
REVIEWED: 35 (35M) [PATCH v13 5/5] rust: remove core::ffi::CStr reexport
2025-07-01 · Tamir Duberstein <hidden> -
STALE365d
REVIEWED: 30 (30M) [PATCH v13 4/5] rust: replace `kernel::c_str!` with C-Strings
2025-07-01 · Tamir Duberstein <hidden> -
STALE365d
REVIEWED: 30 (30M) [PATCH v13 3/5] rust: replace `CStr` with `core::ffi::CStr`
2025-07-01 · Tamir Duberstein <hidden> -
STALE366d
[PATCH v2 1/3] rust: device_id: split out index support into a separate trait
2025-07-01 · FUJITA Tomonori <fujita.tomonori@gmail.com> -
STALE366d
[PATCH v1 1/3] rust: device_id: make DRIVER_DATA_OFFSET optional
2025-06-23 · FUJITA Tomonori <fujita.tomonori@gmail.com> -
STALE359d
[PATCH net 1/4] auxiliary: Allow empty id
2025-06-19 · Sean Anderson <sean.anderson@linux.dev>
Needs attention (review trailers in, no pickup)
Patches with review trailers that haven't landed in mainline and haven't been Acked by a maintainer. Oldest first.
-
STALE132d
REVIEWED: 4 (4M) [PATCH V2] driver core: auxiliary bus: Fix sysfs creation on bind
2026-02-19 · Tariq Toukan <tariqt@nvidia.com> · 1 Reviewed-by